Topic-icon Compile Error: Unparenthesized `a ? b : c ? d : e` is not supported. Use either

More
05 Oct 2022 11:05 #7615

Issue is fixed in latest release vData 3.0.2

Please Log in or Create an account to join the conversation.

  • Arnaud FRERET
  • Arnaud FRERET's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
30 Aug 2022 08:54 #7602

Hello

I have this error in my site

Fatal error: Unparenthesized `a ? b : c ? d : e` is not supported. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)` in /var/www/xxx/components/com_vdata/controllers/vdata.php on line 116
FatalError
HTTP 500 Whoops, looks like something went wrong.
Compile Error: Unparenthesized `a ? b : c ? d : e` is not supported. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)`
ExceptionStack Trace

Symfony\Component\ErrorHandler\Error\

FatalError
in /var/www/xxx/components/com_vdata/controllers/vdata.php (line 116)
$json = json_encode(simplexml_load_string($output->getXMLString())); } $json = str_replace('@attributes','attributes',$json); $json = json_decode($json); $cpu = new stdClass(); $cpu->cpu_info = isset($json->Hardware->CPU->CpuCore[0]->attributes->Model)?$json->Hardware->CPU->CpuCore[0]->attributes->Model.' Cpu Speed'.$json->Hardware->CPU->CpuCore[0]->attributes->CpuSpeed:isset($json->Hardware->CPU->CpuCore->attributes->CpuSpeed)?$json->Hardware->CPU->CpuCore->attributes->CpuSpeed:''; $cpu->cpu_load = isset($json->Vitals->attributes->CPULoad)?$json->Vitals->attributes->CPULoad:''; $cpu->memory_status = isset($json->Memory->attributes->Percent)?$json->Memory->attributes->Percent:''; array_push($datas,$cpu); $host = $_SERVER;


System Information
vData Package Package 3.0.1
PHP Built On Linux s22095112 3.10.0-1127.13.1.el7.x86_64 #1 SMP Tue Jun 23 15:46:38 UTC 2020 x86_64
Database Type mysql
Database Version 10.2.44-MariaDB
Database Collation utf8mb4_general_ci
Database Connection Collation utf8mb4_general_ci
Database Connection Encryption None
Database Server Supports Connection Encryption No
PHP Version 8.1.9
Web Server Apache
WebServer to PHP Interface fpm-fcgi
Joomla! Version Joomla! 4.2.0 Stable [ Uaminifu ] 16-August-2022 13:05 GMT
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.0.0 Safari/537.36

thanks for your help
regards
Arnaud

Attachments:

Please Log in or Create an account to join the conversation.

Cron Job Starts